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Apple Push Notification Service 
(APNs) 

Generating an APN Service Certificate for NotifyMDM 

 

What is APNs  

Apple Push Notification Service (APNs) is a highly secure and efficient system for communicating with iOS 
devices over-the-air (OTA). Each device establishes an accredited and encrypted IP connection with the 
service. The provider, in this case your NotifyMDM server, connects with and sends its notification to the 
APNs, which pushes the notification to the target device.  

An APNs certificate is required to use the Apple Push Notification Service. This guide explains the process of 
obtaining the APNs certificate from Apple and provides instructions on how to upload the certificate to the 
NotifyMDM server via its Dashboard. 

There are various methods of generating the APNs certificate, any of which you can use. This document 
guides you through two methods: 

 The automated process provided via the NotifyMDM dashboard.  

 A method using Microsoft Windows Internet Information Services (IIS) Manager, version 6, 7, or 8. 

 

The Benefits of an APNs Certificate 

The APNs Certificate allows you to use the built-in MDM protocol of Apple iOS devices. NotifyMDM uses the 
Apple Push Notification service to send notifications to the iOS device requesting information. Data is not sent 
through the APNs server only the notifications. The device responds directly to the NotifyMDM server.  

Some of the additional functionality available with Apple advanced MDM includes: 

 Devices support Selective Wipe, Lock Device, and Clear Passcode 

 Full Wipe and Lock Device commands are applied immediately 

 Ability to record and access installed applications on devices 

 Ability to record and access installed configuration profiles on devices 

 Access to additional device statistics 

 Configuration profile updates require no user interaction 

 Enterprise (In-house) Apps 

 Mobile App Management 

 Manage VPP (Redemption) Codes 
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Requirements 

 An Apple ID. It is recommended that you do not use a personal Apple ID, but create a separate 
corporate Apple ID for MDM. Associate the Apple ID with an email account that will remain with your 
company – not an email account that belongs to an individual in the company. You can create an ID 
at https://appleid.apple.com. 

 Firefox® or Safari ®  Web browser 

 

 

  

https://appleid.apple.com/
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APNs Certificate Generation 

Using the APNs Certificate Generation Wizard 
This section explains how to generate and upload the APNs certificate using the APNs Certificate wizard 
provided in the NotifyMDM dashboard.  

 

1. Log in to the NotifyMDM dashboard and select the System Management view. 

2. Select Organization from the left panel. 

3. Click the Set Up (Edit if you are renewing) button beside the APNs Certificate field. 

4. Leave the checkbox beside, I have an APNs certificate (.pfx) generated via a third party (ex: IIS) 
unchecked. 

 

5. Enter the Apple ID you want to use to generate the certificate. 

Note: It is recommended that you do not use a personal Apple ID, but create a separate 
corporate Apple ID for MDM. Associate the Apple ID with an email account that will remain with 
your company – not an email account that belongs to an individual in the company. You can 
create an ID at https://appleid.apple.com 

6. Enter the company’s Legal Organization Name. 

7. Enter the Organization Unit/Dept within the organization. 

8. Enter the organization’s Country, State, and City 

9. Click the Download button to download your Certificate Signing Request (CSR). Click OK at the 
confirmation prompt. 

https://appleid.apple.com/
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10. Select a location to download and save the file named NotifyMDM.request. Remember where you 
store it. Click Save. 

11. Click Next. 

12. To upload the Certificate Signing Request file to Apple, click the Apple Push Certificate Portal link. 

 

13. Sign in to the Apple portal with your Apple ID and Password. 

 
  



NotifyMDM APNs Certificate Generation    7 

14. Click the Create a Certificate button. 

 

15. Read the Terms of Use, check the terms and conditions box, and click the Accept button. 
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16. Click the Browse button and navigate to the location where the NotifyMDM.request file (CSR file) is 
stored. Select it and click Open. 

 

17. Once the file appears in Certificate Signing Request field on the Apple portal page, click the Upload 
button to upload the CSR to Apple. 

18. The Apple portal displays a page confirming the creation of the push certificate. Click Download to 
download the certificate file from Apple. 
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19. Save the certificate file. (Click the download drop-down list. Select the file and drag it to the Desktop 
or another location.) Return to the NotifyMDM APNs wizard. 

 

20. In the Certificate Password field, enter a password to be used for certificate file creation. You will 
not have to remember this password. 

 

21. Click the Upload and Install button. The file displays in the NotifyMDM APNs wizard. 

22. Click Next to display the Summary page. 
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23. Click the Finish button. The APNs certificate appears under the APN Certificate field on the 
Organization Settings page in the format:  com.apple.mgmt.<random string>  (Enabled) 

 

 

Note: The APNs certificate must be renewed annually. The expiration date is displayed on 
the Organization Settings page. You can also use the Test Now button to check the 
certificate’s validity. The test will return the certificate’s activation and expiration dates. 

24. Click Save Changes when you are finished. 

 

 

Updating the APNs Certificate 
1. Log in to the NotifyMDM dashboard and select the System Management view. 

2. Select Organization from the left panel. 

3. Scroll down to the iOS Management information on the Organization Settings page to update 
the certificate or information associated with the certificate. 

 Edit the Apple ID or server address if necessary. 
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 Click the Edit button beside the APNs Certificate to renew, disable, or delete the APNs 
Certificate. (See the following section for the renewal instructions.) 

 
 

4. Click Save Changes when you are finished. 
 

Tip:  You may want to test APNs functionality after an update to the certificate by manually 
updating the APN profile on a device. Open NotifyMDM on an iOS device and tap Config > Load 
Configuration Profile. The device installs the initial profile and, after a brief delay, prompts for 
the user’s Exchange password. If the prompt for Exchange credentials does not occur, resetting 
IIS may resolve issues preventing the APNs from processing. 
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Renewing an APNs Certificate 
The Apple Push Notification service (APNs) certificate must be renewed annually. Organizations can keep 
track of the certificate’s expiration date by setting an alert to occur prior to the date. The expiration date is also 
displayed on the Organization Settings page.  

 

To set the APNs Certificate Expiration alert: 

 From the Organization Management page select Compliance Manager > Alert Settings > System 
Alerts. 

 Enable the Apple Push Notification (APNs) Certificate Expiration alert and configure when you 
want the reminder to begin and how often to be reminded. The default settings are to issue the 
reminder 30 days prior to the expiration and repeat it every day.  

 You can also choose to have an E-mail and/or SMS alert sent to an administrator. 

 

 

Follow the instructions below to renew the APNs certificate that was generated from the Apple Push 
Certificates Portal or from Apple’s iOS Developer Enterprise Program (iDEP). 

Essentially, you follow the same process used to obtain the original certificate. The only difference is in the 
steps taken on the Apple Push Certificates Portal (Steps 4-6 below.) 

 

To renew an APNs certificate: 

1. From the NotifyMDM server dashboard, select System > Organization.  

Click the Edit button next to the APNs Certificate field and choose Renew APNs Certificate. 

Follow the instructions for using the APNs wizard. 
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Applying an APNs Certificate to 
Multiple Organizations 

If you have System Administrator privileges, you can apply an existing APNs certificate to multiple 
organizations on the NotifyMDM server. 

For example, on-premise systems that have categorized various divisions of a company by creating multiple 
organizations can allow those organizations to share one APNs certificate. 

 

1. Log in to the NotifyMDM dashboard and select the System Management view. 

2. Select Organization from the left panel. 

3. Scroll down to the iOS Management section of the Organization Settings page. Click on the link 
to the System Settings page under the APNs Certificate field. This option will not be available if 
you are not logged in as a system administrator. 

 

You can also access System Settings directly by selecting System Management > System 
Administration > System Settings. 

4. On the System Settings page a list of organizations appears in the APNs Settings grid. If there is 
an APNs certificate associated with the organization, the Apple ID, Expiration Date, and 
Certificate Topic (certificate file) are listed beside it. 
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There are several functions you can perform from this grid. 

 Set Up an APNs certificate for the first time for one or multiple organizations 
See also, APNS Certificate Generation. 

 Renew an APNs certificate for one or multiple organizations (click Set Up)  
See also, APNS Certificate Generation. 

 Disable/Enable or Delete an APNs certificate for one or multiple organizations 

 Copy an existing APNs certificate from one organization to one or multiple organizations (Copy To) 
Caution: Copying a certificate will overwrite any existing certificate associated with the organization(s) 
selected. 

 

To select multiple consecutive organizations in the grid, hold the SHIFT key and click on the first and last 
organization. 

To select multiple random organizations in the grid, hold the CTRL key and select organizations. 
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Manual APNs Certificate 
Generation 

Using Microsoft Windows IIS Manager to Generate the APNs Certificate: An Overview 

You will need Windows Server 2003, 2008, or 2012 with administrator permissions. 

 

1. Create a Certificate Signing Request (CSR). (This guide provides instructions for creating the cert 
from Microsoft Windows Internet Information Services (IIS) Manager, version 6, 7, or 8.) 

2. Upload the CSR to the NotifyMDM Certificate Portal. Notify Technology Corporation signs the CSR. 

3. Upload the intermediate certificate (the CSR signed by Notify Technology Corporation) to the Apple 
Push Certificates Portal. Apple issues the certificate. 

4. Download the signed certificate from the Apple Push Certificates Portal and complete the certificate 
request in IIS. 

5. Export the certificate to a file.  

6. Upload the certificate to the NotifyMDM server. 
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Generating an APNs Certificate from Windows Server 
2003 
The following instructions are for generating an APNs certificate from a Windows Server 2003, using Internet 
Information Services (IIS) Manager version 6. You can skip this section if you use Windows Server 2008 or 
2012. Instructions for 2008/2012 are in another section of this document. 

 

Create the Certificate Signing Request (CSR) from IIS Manager 6 

1. Select Start > Control Panel > Administrative Tools > Internet Information Services (IIS) 
Manager. 

2. Select any website from the left panel and right click on it. Select Properties.  

3. Select the Directory Security tab and then click the Server Certificates button in the Security 
section of the menu. This starts the Web Server Certificate Wizard. Click Next to continue. 
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4. Select the Create a new certificate option and click Next.  
Select Prepare the request now, but send it later option and click Next. 

 

  

 
5. Enter a certificate name – one that is easily remembered.  At the Bit length field, select 2048 for the 

encryption level, then place a check in the box labeled, “Select cryptographic service provider (CSP) 
for this certificate.“  Click Next. 
 
From the Available Providers window, select, Microsoft RSA SChannel Cryptographic Provider. 
Click Next. 
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6. Enter the legal name of your Organization and the Organization unit, the department within your 
organization. Click Next. 
In the Common name field, enter a valid Apple ID. This does not have to be an Apple Developer 
account ID, but it is recommended that you use an Apple ID that has been designated for managing 
the corporate APNs certificate. The Apple ID might be in the form of an email address, or possibly a 
display name.  
Click Next. 

 

 

 

 

7. Enter the Country/Region, State/Province, and City/locality of your organization. Click Next. 

At the Certificate Request File Name window, save the CSR to your computer. Record the location 
and filename. This is the file you will upload to the NotifyMDM Certificate Request Portal. Click Next. 

 

 

 

8. Review the information for the certificate request on the Request File Summary window. To make 
revisions, click the Back button. Click Next to accept, and Finish at the completion window. 
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Upload the CSR to the NotifyMDM Certificate Request Portal 

The CSR file you generated using IIS, must be signed by Notify Technology Corporation before you can 
upload it to the Apple Push Certificates Portal. You must upload the CSR file to the NotifyMDM Certificate 
Request Portal for this purpose. You will need: 

 Access to the CSR file  

  A valid NotifyMDM license key 

 

1. Navigate to the NotifyMDM Certificate Portal at https://notifymdm.notify.net/csr/ 

 

2. Browse to select the CSR file. 

3. Enter the NotifyMDM license key issued to you by your Notify Technology Corporation Sales 
Representative. 

4. Click Get Signed Request. 

5. Save the signed request. 

 

 

You are now ready to upload the signed NotifyMDM.request file (the Intermediate Certificate) to the Apple 
Push Certificates Portal. 

https://notifymdm.notify.net/csr/
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Upload the Intermediate Certificate to the Apple Push Certificates Portal 

At the Apple Push Certificates Portal, accept the license agreement and upload the Intermediate Certificate 
that you downloaded from the NotifyMDM Certificate Portal. A new Apple signed Push Certificate is created 
which you will download. 

 

1. Browse to the Apple Push Certificates portal at:  https://identity.apple.com/pushcert/ .  

2. Log in using your Apple ID and password. This does not have to be an Apple Developer 
account ID, but it is recommended that you use an Apple ID that has been designated for 
managing the corporate APNs certificate.   

 
 

3. Select, Create a Certificate. 

 

4. Read the Terms of Use and Accept the End User License Agreement. 

https://identity.apple.com/pushcert/
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5. Select and upload the Intermediate Certificate you downloaded from the NotifyMDM 
Certificate Portal. 
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6. When the upload has completed, a new Certificate for NotifyMDM will appear. Select 
Download to download the Apple signed certificate. 

 

You are now ready to complete the CSR and export the APNs certificate to the NotifyMDM server. 
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Complete the Certificate Request from IIS Manager 6 

 

1. Return to the IIS Manager. Select Start > Control Panel > Administrative Tools > Internet 
Information Services (IIS) Manager. 

2. Select any website from the left panel and right click on it. Select Properties.  

3. Select the Directory Security tab and then click the Server Certificates button in the Security 
section of the menu. This starts the Web Server Certificate Wizard. Click Next to continue. 

4. Select the Process the pending request and install the certificate option and click Next.  

5. Browse to the aps_production_identity.pem file that was provided by Apple.  Click Next. 

 

  

 

6. At the Certificate Summary screen verify that the certificate information is correct and click Next, then 
Finish. 

7. Open the Microsoft Management Console (MMC). Click Start > Run… and enter MMC.  

8. From the File menu, select Add/Remove Snap-in… 
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9. From the drop-down list at Snap-ins added to:, select Console Root and click Add. From the Add 
Standalone Snap-in screen, select Certificates, then click Add.  

 

 

 

10. At the Certificates snap-in screen, select Computer account and click Next. Choose Local 
computer and click Finish.  

 

 

 

11. Click Close. Click OK at the Add/Remove Snap-in screen. 
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12. At the Console Root, expand the directory. Select Certificates > Personal > Certificates. Right click 
on the certificate file and select All Tasks > Export. This opens the Export Wizard. Click Next to 
continue. 

 

 

13. Select Yes to export the private key and click Next. 
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14. Select the Personal Information Exchange – PKCS #12 (.PFX) format and check the Enable 
strong protection box. Click Next. 

 

15. Enter and confirm a password. You will need this password when you upload the certificate to 
NotifyMDM. Click Next. 
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16. Click the Browse button and select the .pfx file that you want to export. Click Next. 

 

 

 

17. Click Finish to complete the certificate export. You will see a message that says the export was 
successful.  

 

Now you are ready to upload the certificate to NotifyMDM. You need the following: 

 APNs certificate file (.pfx format) 

 The password you set when exporting the certificate 

 

Please proceed to Upload the APNs Certificate to NotifyMDM. 
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Generating an APNs Certificate from Windows Server 
2008 or 2012 
The following instructions are for generating an APNs certificate from a Windows Server 2008 or 2012, using 
Internet Information Services (IIS) Manager version 7 or 8. You can skip this section if you use Windows 
Server 2003. Instructions for 2003 are in another section of this document. 

 

Create the Certificate Signing Request (CSR) from IIS Manager 7 or 8 

1. Navigate to Administrative Tools and select Internet Information Services (IIS) Manager. 

2. Select the server name in the left panel, then double-click the Server Certificates option in the 
Security section of the menu.  

 

3. From the Actions menu in the right panel, select Create Certificate Request. This starts the Request 
Certificate wizard. 
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4. Enter the following in the Distinguished Name Properties window: 

 Common name – enter a valid Apple ID. This does not have to be an Apple Developer 
account ID, but it is recommended that you use an Apple ID that has been designated for 
managing the corporate APNs certificate. The Apple ID might be in the form of an email 
address, or possibly a display name. 

 Organization – the legal name of your organization 

 Organization unit – the department within your organization 

 City/locality – city in which your organization is located 

 State/province – abbreviation for state or province in which your organization is located 

 Country/region - abbreviation for country or region in which your organization is located 

 
5. Select Next. 
6. In the Cryptographic Service Provider Properties window, accept the default setting, Microsoft RSA 

SChannel Cryptographic Provider. At the Bit length field, select 2048 for the encryption level. Click 
Next. 
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7. At the File Name window, save the CSR to your computer. Record the location and filename. Click 
Finish. This is the file you upload to the NotifyMDM Certificate Request Portal. 
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Upload the CSR to the NotifyMDM Certificate Request Portal 

The CSR file you generated using IIS, must be signed by Notify Technology Corporation before you can 
upload it to the Apple Push Certificates Portal. You must upload the CSR file to the NotifyMDM Certificate 
Request Portal for this purpose. You will need: 

 Access to the CSR file  

  A valid NotifyMDM license key 

 

1. Navigate to the NotifyMDM Certificate Portal at https://notifymdm.notify.net/csr/ 

 

2. Browse to select the CSR file. 

3. Enter the NotifyMDM license key issued to you by your Notify Technology Corporation Sales 
Representative. 

4. Click Get Signed Request. 

5. Save the signed request. 

 

 

You are now ready to upload the signed NotifyMDM.request file (the Intermediate Certificate) to the Apple 
Push Certificates Portal. 

https://notifymdm.notify.net/csr/
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Upload the Intermediate Certificate to the Apple Push Certificates Portal 

At the Apple Push Certificates Portal, accept the license agreement and upload the Intermediate Certificate 
that you downloaded from the NotifyMDM Certificate Portal. A new Apple signed Push Certificate is created 
which you will download. 

 

1. Browse to the Apple Push Certificates portal at:  https://identity.apple.com/pushcert/ .  

2. Log in using your Apple ID and password. This does not have to be an Apple Developer 
account ID, but it is recommended that you use an Apple ID that has been designated for 
managing the corporate APNs certificate.  

 
 

3. Select, Create a Certificate. 

 

4. Read the Terms of Use and Accept the End User License Agreement. 

https://identity.apple.com/pushcert/
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5. Select and upload the Intermediate Certificate you downloaded from the NotifyMDM 
Certificate Portal. 
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6. When the upload has completed, a new Certificate for NotifyMDM will appear. Select 
Download to download the Apple signed certificate. 

 

You are now ready to complete the CSR and export the APNs certificate to the NotifyMDM server. 
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Complete the Certificate Request from IIS Manager 7 or 8 

 

1. Return to Internet Information Services (IIS) Manager > Server Certificates and select Complete 
Certificate Request from the Actions menu in the right panel. This starts the Complete Certificate 
Request wizard. 

 

2. Browse to the aps_production_identity.pem file that was provided by Apple and enter a Friendly 
name. This is simply a label you give the cert to easily distinguish it. You might want to give it a name 
in which your company is identified. 

 

3. Select OK to install the certificate to the server. You should see the certificate listed in the center 
panel of Server Certificates. 
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4. Export the certificate so that it can be uploaded to NotifyMDM. Right click on the certificate you just 
installed and select Export. 

 

5. Save the file to your Desktop in the .pfx format. You must set a password. You will need this 
password when you upload the certificate to NotifyMDM. 
 

 

6. You have successfully generated your APNs certificate.  
 

Now you are ready to upload the certificate to NotifyMDM. You need the following: 

 APNs certificate file (.pfx format) 

 The password you set when exporting the certificate 

 

Please proceed to Upload the APNs Certificate to NotifyMDM. 
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Upload the APNs Certificate to NotifyMDM 
This section explains how to upload the APNs certificate to NotifyMDM using the NotifyMDM dashboard. You 
need: 

 APNs certificate file (the .pfx format) 

 The password you set when exporting the certificate 

 

1. Log in to the NotifyMDM dashboard and select the System Management view. 

2. Select Organization from the left panel. 

3. Click the Setup (Edit if you are renewing) button beside the APNs Certificate field. 

4. Check the box beside, I have an APNs certificate (.pfx) generated via a third party (ex: IIS) 

 

5. Enter the Apple ID used to generate the certificate, if you want to display it for reference on the 
Organization Settings page. This information can be useful at renewal time. 

6. Click Next. 

7. In the Certificate Password field, enter the password you set when exporting the certificate. 

8. Click the Upload and Install button, then navigate to and select the APNs certificate file (.pfx format).  
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9. When the file name displays in the wizard, click Next. 

 
 

10. The certificate information displays in the wizard. Click the Finish button. 

After you have uploaded an APNs certificate, it appears under the APN Certificate field on the 
dashboard in the format:  com.apple.mgmt.<random string>  (Enabled) 

 

 

Note: The APNs certificate must be renewed annually. The expiration date is displayed on 
the Organization Settings page. You can also use the Test Now button to check the 
certificate’s validity. The test will return the certificate’s activation and expiration dates. 

11. Click Save Changes when you are finished. 
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Updating the APNs Certificate 
1. Log in to the NotifyMDM dashboard and select the System Management view. 

2. Select Organization from the left panel. 

3. Scroll down to the iOS Management information on the Organization Settings page to update 
the certificate or information associated with the certificate. 

 Edit the Apple ID or server address if necessary 

 

 Click the Edit button beside the APNs Certificate to renew, disable, or delete the APNs 
Certificate. (See the following section for the renewal instructions.) 

 
 

4. Click Save Changes when you are finished. 

Tip:  You may want to test APNs functionality after an update to the certificate by manually 
updating the APN profile on a device. Open NotifyMDM on an iOS device and tap Config > Load 
Configuration Profile. The device installs the initial profile and, after a brief delay, prompts for 
the user’s Exchange password. If the prompt for Exchange credentials does not occur, resetting 
IIS may resolve issues preventing the APNs from processing. 
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Renewing an APNs Certificate 
The Apple Push Notification service (APNs) certificate must be renewed annually. Organizations can keep 
track of the certificate’s expiration date by setting an alert to occur prior to the date. The expiration date is also 
displayed on the Organization Settings page.  

To set the APNs Certificate Expiration alert: 

 From the Organization Management page select Compliance Manager > Alert Settings > System 
Alerts. 

 Enable the Apple Push Notification (APNs) Certificate Expiration alert and configure when you 
want the reminder to begin and how often to be reminded. The default settings are to issue the 
reminder 30 days prior to the expiration and repeat it every day.  

 You can also choose to have an E-mail and/or SMS alert sent to an administrator. 

 

 

Follow the instructions below to renew the APNs certificate that was generated from the Apple Push 
Certificates Portal or from Apple’s iOS Developer Enterprise Program (iDEP). 

Essentially, you follow the same process used to obtain the original certificate. The only difference is in the 
steps taken on the Apple Push Certificates Portal (Steps 4-6 below.) 

To renew an APNs certificate: 

2. Create a new Certificate Signing Request (CSR) by using IIS Manager (See the complete 
instructions: IIS Manager 6 or IIS Manager 7/8) 

3. Upload the CSR to the NotifyMDM Certificate Request Portal. Click Get Signed Request and save 
the signed request file. See the complete instructions. 

4. Go to the Apple Push Certificates Portal at https://identity.apple.com/pushcert/ . 

 If you originally obtained the certificate from the Apple Push Certificates Portal, log in with the 
Apple ID you used to generate the certificate. 

 If you originally obtained the certificate through iDEP, log in with the Apple ID for the iDEP 
Agent account. 

  

https://identity.apple.com/pushcert/
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5. On the page where your certificate is listed, click the Renew button next to the APNs certificate you 
are renewing. 

 
 

6. On the Renew Push Certificate page, click the Browse button and select the .request file (a .plist file 
format) to upload. Click Upload. 

 

7. The page where certificates are listed displays the certificate with a new expiration date. Click the 
Download button next to the renewed certificate to download it and save it as a .pem file. 

8. Use IIS to complete the CSR (See the complete instructions: IIS Manager 6 or IIS Manager 7/8) 

9. From the NotifyMDM server dashboard, upload the renewed certificate.  

Select System Management > Organization.  

Click the Edit button next to the APNs Certificate field and choose Renew APNs Certificate. 

Follow the instructions for uploading the certificate Uploading the APNs Certificate.  

 

 


